MC Spoo
15Jun/110

Geek Success

If you're not a geek, the following may seem trite, and otherwise stupid.

There's something about succeeding at troubleshooting that is extremely satisfying. Maybe this applies to everything in life.
Examples: I recently dove further into the deep end and decided to build my own computer. I selected the parts online (Tiger Direct) and ordered them. My new system is mostly a kit, and partly some add ons I selected. Phenom II 1001T 6 core processor. 4GB Corvair Venegenance RAM. 1TB HD. ASUS Motherboard. Saphire Radeon 5700 1TB GDDR3, 550W Power Supply. Windows 7 Pro 64-bit. It's a Beast, really. Which is what I named it (THEBEAST)... and it'll grow more beastly, as I add more RAM (16GB, anyone?) and upgrade the HD to a 1.5TB 7200rpm. The current spins only at 5900rpm, which leaves my Windows Index score at 5.9.

In any case, it was NOT simple to set up. First off: I assembled everything, and then nothing would load. It seemed like most of the machine was working (fans, lights, drive, etc) but the video card wasn't working... so I ordered a cheaper PCI-E video card... last night, I decided to just disassemble and reassemble the entire kit. I carefully replugged everything, including all the jumpers and found *3* jumpers were just plastic (jumpers should be lined with plastic, with metal connectors inside... ) I scrambled to look through my parts bin, when I realized... I just pitched out/recycled the majority of my parts bin. ARGH! Luckily, I found a very old VESA card that had 4 jumpers on it. I replaced the bad jumpers... completed the reassembly... VOILA! I had a bootable system, and full Windows 7 installation with all necessary drivers within the hour. Alas, I don't need the cheap PCI-E Video card now. What to do...

Backing up a bit... before I left for work, I had a circ workstation fail to recognize an RFID tag reader. I surmise the system has been jostled around extensively, and the USB connections had been disconnected repeatedly. My feeling then was that the Tag reader was fried. Not good (expensive equipment!) So this morning, fresh from my triumph of last night, I dove into rethinking the workstation issues...

I removed the workstation from the Domain. I reconnected it to the domain. No go (but the error messages in the application logs went away!). So then I opened the software to control the Tag Reader and found I can reset the ports... so I went through the ports. It starts with port 4 (no good). 5. 6. AHA! 7! Port 7 worked.

So, this partially verified my original theory from yesterday. rapid unpluging/loosening of the USB connection caused the ports to become "reassigned". So something else got reassigned into port 4 when then Tag Reader was disconnected. Voila! Obvious solution: inform circ staff to stop kicking the computer.

With my new Kit computer not working, I spent all day yesterday with this... cloud of failure hanging over my head. This doom cloud of technical failure, hovering over my skull, randomly reminding me "you couldn't get it to work! HAW HAW!". So when I end up troubleshooting something at work, I didn't have it.

Now I gots it back. It's MINE. THEBEAST lives, snarling and growling... waiting to be connected to the 23" flat panel... circ workstations are all back in shape and working properly... and I'm going to a picnic before a meeting today. Yup.

This is my roller coaster. There are many like it, but this one is mine. You may think my roller coaster is lame and weak. That's okay. I'm happy to leap over my little hurdles, and fall down my little valleys. It's not how many times I fall: it's how many times the computer works because I laid my hands upon it.

Filed under: Creativity, Work No Comments